atiscript

— OUTDATED since anno 2000

:: about

Das atiscript soll euch behilflich sein beim Bilden der “fglrx” Module. Es gibt immer wieder Probleme mit den Ati Treibern und dem Linux Kernel. Diese Fehler kann man meistens mit einem Patch beseitigen. Dieses Script laedt sich alle benoetigten Treiber und Patches herunter und Installiert diese Automatisch. Danach sollten wenn nur noch Probleme mit der Xorg Config geben.
Zurzeit Unterstuetzt mein atiscript folgende Treiber:

Ati-8.23.7 and Linux 2.6.15 on Xorg
Ati-8.22.5 and Linux 2.6.15 on Xorg
Ati-8.8.25 and Linux 2.6.10 on Xorg
Ati Run-Installer 8.23.7
Ich habe mich darauf eingelassen immer nur die neusten Kernel in der 2.6er Reihe zu unterstuetzen. Ich denke jede neuere Distribution besitzt einen funktionstuechtigen 2.6er Kernel und Ati empfiehlt einen Kernel aus der 2.6er Reihe.

:: howto

Change your login to root:
steffen@linux: ~> suchange to the directory where you saved the script and decompress it:
root@linux: ~> cd /path/to/atiscript
root@linux: ~> tar xvzf atiscript-0.1.tar.gzcd into the newly created subdirectory:
root@linux: ~> cd atiscript-0.1/now you can start the atiscript by typing:
root@linux: ~> sh ./atiscript.sh

:: download

atiscript-0.1.1
atiscript-0.1
atiscript-0.0.9
atiscript-0.0.8
atiscript-0.0.7b
atiscript-0.0.7a
atiscript-0.0.7
atiscript-0.0.5
atiscript-0.0.4
atiscript-0.0.3
atiscript-0.0.2
atiscript-0.0.1

:: changelog

atiscript 0.1.1 Changelog

:: version-1.1
ati driver 8.23.7 added (run and tar.gz)

:: version-1.0
minor fix 8.21.7 patchset ( not recommended to download the patch)

:: version-0.0.9
installer 8.22.5

:: version-0.0.8
clean the code
set all files online
installer 8.21.7 + patchset

:: version-0.0.7b
installer minor fixes
installer 8.16.20

:: version-0.0.7a
minor fixes
run file added from ati

:: version-0.0.7
Ati-8.14.13 supported on 2.6.12

:: version-0.0.6
Ati-8.14.13 supported on 2.6.11

:: version-0.0.5
Check if files already downloaded

:: version-0.0.4
Download fix

:: version-0.0.3
Ati-8.12.10 and Linux 2.6.11 supported

:: version-0.0.2
Ati-8.10.19 and Linux 2.6.11 supported

:: version-0.0.1
Ati-8.10.19 and Linux 2.6.10 supported
Ati-8.8.25 and Linux 2.6.10 supported
Ati-3.14.6 and Linux 2.6.10 supported
Primary System stands

Leave a Reply

Your email address will not be published.

Time limit is exhausted. Please reload CAPTCHA.

This site uses Akismet to reduce spam. Learn how your comment data is processed.